From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Markers

Markers are used to denote frames at which something significant happens – it could be that a character’s animation starts, the camera changes position, or a door opens, for example. Markers can be given names to make them more meaningful at a quick glance. They are available in many of Blender’s windows, under different forms. Unlike the keyframes, markers are always placed at a whole frame number, you cannot e.g. set a marker at “frame 2.5”.

Markers can be created and edited in all of the following editors (including their different modes):

A marker created in one of these windows will also appear in all others that support them, including:

There are Timeline Markers and Pose Markers in Blender.

Timeline Markers

Timeline markers are used to:

  • Switching multiple cameras.
  • Synchronization timing keyframes with markers.

Pose markers

Pose markers is another type of markers, that are specific to the armatures and are used to denote poses in the Action Editor mode of Dope Sheet editor.

Click the Action Editor menu Marker > Show Pose Markers to see pose markers.

With this enabled, creating markers will add only pose markers in the Action Editor!

With Show Pose Markers disabled, you may select and edit only timeline markers in the Action Editor.

Pose markers are related to the pose libraries, and are discussed in detail here.

Timeline markers is possible to convert to the Pose markers with Marker > Make Markers Local. Note that the original Timeline marker will be gone. If you want to keep it, make a duplicate before you convert.

Visualization

Standard

Timeline markers: small but useful.

Most of the window types visualize markers the same way: as small triangles at their bottom, white if unselected or yellow if selected.

If they have a name, this is shown to their right, in white when the marker is selected. See (Timeline markers: small but useful).

3D View

Marker in a 3D View.

The 3D View windows do not allow you to create/edit/remove markers, they just show their name between <> at there bottom left corner, near the active object’s name, when you are at their frame (see Marker in a 3D view).

Pose Markers

Pose markers in the Action Editor mode of the Dope Sheet editor.

Pose markers show a diamond-shaped icon in Action Editor mode of Dope Sheet editor. See (Pose markers in the Action Editor mode of the Dope Sheet editor).

Creating and Editing Markers

Pose markers are created automatically at the moment adding new pose in Pose Library. Methods of the editing are same for both Timeline and Pose markers.

Creating Timeline Markers

Mode: all modes

Hotkey: M

Menu: Marker » Add Marker

The simplest way to add a marker is to move to the frame where you would like it to appear, and press M.

Alternatively, you can press AltA (or the “playback” button of the Timeline window) to make the animation play, and then hit M at the appropriate points. This can be especially useful to mark the beats in some music.

Selecting Markers

Mode: all modes

Hotkey: RMB Template-RMB.png, ⇧ ShiftRMB Template-RMB.png, A, B

Click RMB Template-RMB.png on the marker’s triangle to select it. Use ⇧ ShiftRMB Template-RMB.png to (de)select multiple markers.

To (de)select all markers use A. There are using border (de)select them with B.

The corresponding options are found in the Select menus of the editors, where the markes are using.

Naming Markers

Mode: all modes

Hotkey: CtrlM

Menu: Marker » Rename Marker

Having dozens of markers scattered throughout your scene’s time won’t help you much unless you know what they stand for. You can name a marker by selecting it, pressing CtrlM, typing the name, and pressing the OK button.

Moving Markers

Mode: all modes

Hotkey: G

Menu: Marker » Grab/Move Marker

Once you have one or more markers selected, hit G to move them, and confirm the move with LMB Template-LMB.png or ↵ Enter (as usual, cancel the move with RMB Template-RMB.png, or Esc).

By default, you grab the markers in one-frame steps, but if you hold Ctrl, the markers will move in steps corresponding (defined by Frame Rate option in Dimensions panel of Render context) to one second – so if you have set your scene to 25 fps, the markers will move in twenty-five-frames steps.

Duplicating Markers

Mode: all modes

Hotkey: ⇧ ShiftD

Menu: Marker » Duplicate Marker

You can duplicate the selected markers by hitting ⇧ ShiftD. Once duplicated, the new ones are automatically placed in grab mode, so you can move them where (or rather when) you want.

Deleting Markers

Mode: all modes

Hotkey: X

Menu: Marker » Delete Marker

To delete the selected marker(s) simply press X and confirm the pop-up message with LMB Template-LMB.png.

Using Timeline Markers for switching Multiple Cameras

To change cameras mid-animation, you need to use markers.

Note that markers behave like keyframes, so you will need at least two markers with two cameras bound to them to have any camera switching.

For quickly "bind camera to marker" by following the step-by-step below:

  • Select your camera (to be binded to timeline) in the 3D view with RMB Template-RMB.png-click or with Object Data context for camera in Properties window.

Select the camera

  • Hover over the timeline (make sure mouse is within Timeline panel), jump to a specific frame, create a marker there by hitting M on the keyboard or select corresponding item - Marker » Add Marker.

Add marker.

  • Now, while still hovering on the timeline, press CtrlB to Bind Camera to Markers or select corresponding item - View » Bind Camera to Markers.

Binding camera to the marker.

  • Continue with next camera.
  • Now, if you jump to inside camera (by hitting numpad Zero), it will switch camera specified by marker as you scrub along the timeline.

Switching Cameras.

Synchronization timing keyframes with markers

Option Sync Markers in View menu of the Action Editor mode of the Dope Sheet editor.

Anothe the usage Timeline markers is synchronization timing keyframes with markers in the Dope Sheet and Video Sequence Editor (the option Sync Markers in View menu). This allows to tape editing or final cut yours actions, sequences, scenes, movie and audio clips.

Blender3D FreeTip.gif
This is the old manual!
For the current 2.7x manual see http://www.blender.org/manual/


User Manual

World and Ambient Effects

World

Introduction
World Background

Ambient Effects

Mist
Stars (2.69)


Game Engine

Introduction

Introduction to the Game Engine
Game Logic Screen Layout

Logic

Logic Properties and States
The Logic Editor

Sensors

Introduction to Sensors
Sensor Editing
Common Options
-Actuator Sensor
-Always Sensor
-Collision Sensor
-Delay Sensor
-Joystick Sensor
-Keyboard Sensor
-Message Sensor
-Mouse Sensor
-Near Sensor
-Property Sensor
-Radar Sensor
-Random Sensor
-Ray Sensor
-Touch Sensor

Controllers

Introduction
Controller Editing
-AND Controller
-OR Controller
-NAND Controller
-NOR Controller
-XOR Controller
-XNOR Controller
-Expression Controller
-Python Controller

Actuators

Introduction
Actuator Editing
Common Options
-2D Filters Actuator
-Action Actuator
-Camera Actuator
-Constraint Actuator
-Edit Object Actuator
-Game Actuator
-Message Actuator
-Motion Actuator
-Parent Actuator
-Property Actuator
-Random Actuator
-Scene Actuator
-Sound Actuator
-State Actuator
-Steering Actuator
-Visibility Actuator

Game Properties

Introduction
Property Editing

Game States

Introduction

Camera

Introduction
Camera Editing
Stereo Camera
Dome Camera

World

Introduction

Physics

Introduction
Material Physics
No Collision Object
Static Object
Dynamic Object
Rigid Body Object
Soft Body Object
Vehicle Controller
Sensor Object
Occluder Object

Path Finding

Navigation Mesh Modifier

Game Performance

Introduction
System
Display
Framerate and Profile
Level of Detail

Python API

Introduction
Bullet physics
VideoTexture

Deploying

Standalone Player
Licensing of Blender Game

Android Support

Android Game development