From BlenderWiki

Jump to: navigation, search
Blender3D FreeTip.gif
IMPORTANT! Do not update this page!
We have moved the Blender User Manual to a new location. Please do not update this page, as it will be locked soon.

Мітки

Мітки (markers) або ще «маркери» — це графічний засіб інтерфейсу Blender'а для позначення кадрів на Шкалі Часу, в яких сталася або планується певна події процесу анімування. Це може бути початок анімації персонажа, зміни позиції камери, або врешті-решт, наприклад, відкриття дверей. Мітки доступні для іменування, що полегшує їх пошук та впорядкування. Вони видимі у тих редакторах та їх режимах, де застосовується Шкала Часу, а також у 3D-вигляді. На відміну від ключ-кадрів, мітки завжди розставляються відповідно до цілочислених номерів кадрів, ви не можете встановити мітку у часову позицію «кадр 2.5».

Робота з мітками здійснються у таких редакторах та їх режимах:

Мітка, створена в одному з цих редакторів, також буде показуватися в інших редакторах з часовою шкалою, зокрема, і у вікні:

Мітки у Blender'і бувають двох видів: для Шкали Часу (Timeline Markers) (стандартні) та для Поз (Pose Markers).

Мітки Шкали Часу

Мітки Шкали Часу є стандартними маркерами часування анімаційних подій та доступні там, де застосовується Шкала Часу, а також у 3D-вигляді. Вони використовуються для:

  • Позначення важливих подій у ході анімації на Шкалі Часу.
  • Перемикання (зміни) вигляду з однієї камери на іншу при використанні одночасно кількох камер в анімації.
  • Синхронізування часування (хронометражу) ключ-кадрів (що описують пряме анімування) та міток (описують, як правило, опосередковане анімування).

Мітки Поз

Мітки Поз — це специфічний підвид маркерів у Blender'і, що застосовується для часування і позначення поз персонажа у режимі «Редактор Дій» (Action Editor) редактора Аркуш Експозицій (Dope Sheet).

Для вмикання режиму їх використання у Редакторі Дій використовується команда меню Marker (Мітка) > Show Pose Markers (Показати Мітки Поз).

При вмиканні цього режиму показу будь-яке створення міток буде у Редакторі Дій додавати тільки мітки поз! Після вимкнення даного режиму стане знову доступна робота зі стандартними мітками шкали часу.

Мітки поз прив'язані до та залежать від бібліотек поз, в яких ці пози зберігаються, про що детально описується тут.

Мітки шкали часу можна конвертувати у мітки пози за допомогою команди меню Marker (Мітка) > Make Markers Local (Зробити Мітки Локальними). Зверніть увагу, що після конвертації оригінальна мітка шкали часу не зберігається. Щоб її зберегти, зробіть її дублікат перед конвертуванням.

Візуальне представлення міток

Стандартне представлення міток шкали часу

Мітки Шкали Часу: такі маленькі, але такі корисні...

У більшості редакторів шкально-часові мітки візуально представляються однаково: у вигляді маленьких трикутників, що більшою стороною лежать на шкалі, а менші сторони направлені угору, та які забарвлені білим кольором, коли невиділені, та забарвлюються жовтим — при їх виділенні.

Імена міток розміщуються справа зверху над трикутником.

Візуальне представлення міток шкали часу у 3D-вигляді

Мітка у 3D-Вигляді.

Вікно «3D-Вигляд» не дозволяє створювати, редагувати та переміщувати мітки, а тільки показує їх імена у кутових лапках «<>» у нижньому лівому куті біля імені активного (виділеного) об'єкта, коли курсор на Шкалі Часу знаходиться у кадрі, для якого встановлена мітка.

Візуальне представлення міток поз у Редакторі Дій

Мітки поз у режимі «Редактор Дій» редактора Аркуш Експозицій.

Мітки поз показуються у вигляді ромбиків діамантової форми тільки у у режимі «Редактор Дій» (Action Editor) редактора Аркуш Експозицій (Dope Sheet).

Створення та редагування міток

Мітки Поз створюються автоматично при застосуванні пози з Бібліотеки Поз (Pose Library) до персонажа та при доданні міток у режимі «Редактор Дій» у редакторі Аркуш Експозицій. Способи ж редагування є однаковими для міток Поз та міток Шкали Часу.

Створення міток Шкали Часу

Mode: Усі режими

Hotkey: M

Menu: Marker » Add Marker (Мітка > Додати Мітку)

Найпростіший спосіб додати мітку на Шкалі Часу — перейти на потрібний її кадр та натиснути швидку клавішу M.

Альтернативно, можна запустити відтворення анімації за допомогою AltA (чи кнопки «Відтворити» у заголовку Шкали Часу), дочекатись потрібного кадру та швидко на ньому натиснути M. Це може бути корисним для позначень, наприклад, ритму для певного аудіо.

Виділення міток

Mode: Усі режими

Hotkey: RMB Template-RMB.png, ⇧ ShiftRMB Template-RMB.png, A, B

Клацок RMB Template-RMB.png на трикутнику мітки виділить її. Швидка клавіша ⇧ ShiftRMB Template-RMB.png дозволяє виділяти та знімати виділення одночасно з кількох міток.

Для (зне)виділення усіх міток на Шкалі Часу використовується швидка клавіша A. Також для (зне)виділу міток доступний «Виділ Рамкою» (B).

Відповідні команди виділення також доступні у меню Select (Виділ) редакторів та вікон, в яких використовується Шкала Часу.

Іменування міток

Mode: Усі режими

Hotkey: CtrlM

Menu: Marker » Rename Marker (Мітка > Перейменувати Мітку)

Наявність десятків міток, розкиданих по Шкалі Часу вашої сцени, немає ніякого сенсу, допоки не видно, що вони позначають. Щоб запобігти плутанині та втраті часу на пошук потрібного, іменуйте всі встановлені мітки.

Для іменування мітки, виділіть її, натисніть швидку клавішу CtrlM, введіть потрібне ім'я у спливне вікно, що з'явиться, та натисніть кнопку «OK».

Переміщення міток

Mode: Усі режими

Hotkey: G

Menu: Marker » Grab/Move Marker (Мітка > Захопити/Перемістити Мітку)

Після виділення мітки ви можете переміщати її по Шкалі Часу, натиснувши швидку клавішу G, рухаючи мишу вліво або вправо, та підтвердити переміщення LMB Template-LMB.png або ↵ Enter (чи скасувати стандартним способом переміщення — RMB Template-RMB.png або Esc).

Стандартно, мітка буде переміщуватися на один кадр. Утримання ж натисненою Ctrl у ході пересування буде переміщувати мітку покроково на визначену опцією Frame Rate (Частота Кадрів) (секція-панель Dimensions (Виміри) у контексті Render (Візуалізація)) кількість кадрів, що вміщає одна секунда — тобто, якщо частота кадрів для сцени буде 25 fps, то мітка буде переміщуватися кроками через двадцять п'ять кадрів.

Дублювання міток

Mode: Усі режими

Hotkey: ⇧ ShiftD

Menu: Marker » Duplicate Marker (Мітка > Дублювати Мітку), Marker » Duplicate Marker to Scene... (Мітка > Дублювати Мітку у Сцену...)

Ви можете дублювати виділені мітки за допомогою швидкої клавіші ⇧ ShiftD. Після операції дублювання новостворена мітка поміщується у режим переміщення, що дає вам змогу встановити її там, де потрібно.

Команда Duplicate Marker to Scene... (Мітка > Дублювати Мітку у Сцену...) дозволяє переносити мітки в інші сцени вашого проекту.

Видалення міток

Mode: Усі режими

Hotkey: X

Menu: Marker » Delete Marker (Мітка > Видалити Мітку)

Для видалення виділених міток зі сцени просто натисніть X та підтвердіть операцію видалення клацком LMB Template-LMB.png.

Використання міток Шкали Часу для перемикання між Камерами у ході анімації

Для зміни камери (перемикання між їх виглядами) у ході анімації використовуються стандартні мітки Шкали Часу.

Зверніть увагу, що задіяні таким чином мітки, поводять себе як і ключ-кадри, тому вам необхідно мати мінімум дві мітки і мінімум дві камери для прив'язування до перших, щоб отримати перемикання камер.

Для швидкого «прив'язування камер до міток»:

  • Виділіть у 3D-вигляді першу камеру для прив'язки до мітки, клацнувши RMB Template-RMB.png на ній або скористайтесь контекстом Object Data (Дані Об'єкта) для камер у вікні «Властивості» чи вікном Outliner (Структуратор).

Вибір потрібної камери з доступних у сцені

  • Перейдіть на потрібний кадр та додайте мітку M (Marker » Add Marker).

Додання мітки.

  • Утримуючи курсор миші над Шкалою Часу натисніть CtrlB або скористайтесь командою меню View » Bind Camera to Markers (Прив'язка Камери до Міток).

Прив'язування камери до мітки.

  • Зробіть це ж саме в потрібному кадрі для другої камери.
  • Тепер, можете перемикнутись на вигляд з камери (0 NumPad) та прокрутити анімацію і побачити, як перемикаються камери.

Перемикання камер.

Синхронізація часування ключ-кадрів з мітками

Опція Sync Markers у меню View у режимі «Action Editor» редактора «Dope Sheet».

Іншим призначенням міток Шкали Часу є синхронізація часування (хронометражу) ключ-кадрів з мітками у редакторі Аркуш Експозицій (Dope Sheet) та редакторі Відеоряду (Video Sequence Editor) (опція Sync Markers (Синхронізація Міток)). Вона дозволяє вам монтувати в кінцевий відеоряд анімаційні дії, відеоряди, сцени, відео- та аудіокліпи.




Попередня: Набори Ключів | Головна | Наступна: Шляхи Руху